import Foundation
let pattern = #"\b[\(\d\s\)-]{8,}\b|(\d\s?){8,12}\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"0944 888 890/ 0903 126 233 | phon0944 888 890/ 0903888 890/ 0903 126 233 | phon0944 888 890/ 84 0903 126 233 | phongnguyen@huuphongplastic.vn/ thaongo@huuphongplastic.vn"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)