$re = '/\b[\(\d\s\)-]{8,}\b|(\d\s?){8,12}\b/';
$str = '0944 888 890/ 0903 126 233 | phon0944 888 890/ 0903888 890/ 0903 126 233 | phon0944 888 890/ 84 0903 126 233 | phongnguyen@huuphongplastic.vn/ thaongo@huuphongplastic.vn';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;