use strict;
my $str = '0944 888 890/ 0903 126 233 | phon0944 888 890/ 0903888 890/ 0903 126 233 | phon0944 888 890/ 84 0903 126 233 | phongnguyen@huuphongplastic.vn/ thaongo@huuphongplastic.vn';
my $regex = qr/\b[\(\d\s\)-]{8,}\b|(\d\s?){8,12}\b/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";