const regex = /\b[\(\d\s\)-]{8,}\b|(\d\s?){8,12}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[\\(\\d\\s\\)-]{8,}\\b|(\\d\\s?){8,12}\\b', 'g')
const str = `0944 888 890/ 0903 126 233 | phon0944 888 890/ 0903888 890/ 0903 126 233 | phon0944 888 890/ 84 0903 126 233 | phongnguyen@huuphongplastic.vn/ thaongo@huuphongplastic.vn`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);