re = /\b[\(\d\s\)-]{8,}\b|(\d\s?){8,12}\b/
str = '0944 888 890/ 0903 126 233 | phon0944 888 890/ 0903888 890/ 0903 126 233 | phon0944 888 890/ 84 0903 126 233 | phongnguyen@huuphongplastic.vn/ thaongo@huuphongplastic.vn'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result