# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b[\(\d\s\)-]{8,}\b|(\d\s?){8,12}\b"
test_str = "0944 888 890/ 0903 126 233 | phon0944 888 890/ 0903888 890/ 0903 126 233 | phon0944 888 890/ 84 0903 126 233 | phongnguyen@huuphongplastic.vn/ thaongo@huuphongplastic.vn"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.