// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)yt(?<ytVer>[a-z])(?<ytID>[a-zA-Z0-9-_]{8,11})").unwrap();
let string = "https://www.youtube.com/watch?v=f7dWJcJgEjE?list
https://youtu.be/voceyAq-R9E
https://www.youtube.com/embed/f7dWJcJgEjE
https://youtu.be/watch?v=DKbQFMOEFTs
ytaDKbQFMOEFTs
ytzvoceyAq-R9E
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}