package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)yt(?<ytVer>[a-z])(?<ytID>[a-zA-Z0-9-_]{8,11})`)
var str = `https://www.youtube.com/watch?v=f7dWJcJgEjE?list
https://youtu.be/voceyAq-R9E
https://www.youtube.com/embed/f7dWJcJgEjE
https://youtu.be/watch?v=DKbQFMOEFTs
ytaDKbQFMOEFTs
ytzvoceyAq-R9E
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}