# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"yt(?<ytVer>[a-z])(?<ytID>[a-zA-Z0-9-_]{8,11})"
test_str = ("https://www.youtube.com/watch?v=f7dWJcJgEjE?list\n"
"https://youtu.be/voceyAq-R9E\n"
"https://www.youtube.com/embed/f7dWJcJgEjE\n"
"https://youtu.be/watch?v=DKbQFMOEFTs\n\n"
"ytaDKbQFMOEFTs\n"
"ytzvoceyAq-R9E\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.