use strict;
my $str = 'https://www.youtube.com/watch?v=f7dWJcJgEjE?list
https://youtu.be/voceyAq-R9E
https://www.youtube.com/embed/f7dWJcJgEjE
https://youtu.be/watch?v=DKbQFMOEFTs
ytaDKbQFMOEFTs
ytzvoceyAq-R9E
';
my $regex = qr/yt(?<ytVer>[a-z])(?<ytID>[a-zA-Z0-9-_]{8,11})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}