const regex = /yt(?<ytVer>[a-z])(?<ytID>[a-zA-Z0-9-_]{8,11})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('yt(?<ytVer>[a-z])(?<ytID>[a-zA-Z0-9-_]{8,11})', 'gm')
const str = `https://www.youtube.com/watch?v=f7dWJcJgEjE?list
https://youtu.be/voceyAq-R9E
https://www.youtube.com/embed/f7dWJcJgEjE
https://youtu.be/watch?v=DKbQFMOEFTs
ytaDKbQFMOEFTs
ytzvoceyAq-R9E
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}