re = /yt(?<ytVer>[a-z])(?<ytID>[a-zA-Z0-9-_]{8,11})/m
str = 'https://www.youtube.com/watch?v=f7dWJcJgEjE?list
https://youtu.be/voceyAq-R9E
https://www.youtube.com/embed/f7dWJcJgEjE
https://youtu.be/watch?v=DKbQFMOEFTs
ytaDKbQFMOEFTs
ytzvoceyAq-R9E
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end