using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"yt(?<ytVer>[a-z])(?<ytID>[a-zA-Z0-9-_]{8,11})";
string input = @"https://www.youtube.com/watch?v=f7dWJcJgEjE?list
https://youtu.be/voceyAq-R9E
https://www.youtube.com/embed/f7dWJcJgEjE
https://youtu.be/watch?v=DKbQFMOEFTs
ytaDKbQFMOEFTs
ytzvoceyAq-R9E
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}