import Foundation
let pattern = #"(\d+\n)|(\d+]\n)|(\d\s+\n)|(\d+$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Edicifio con pilar incrustado [235238]
Edicifio32 con pi-lar incrus_tado 235234
Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 235
Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)