use strict;
my $str = 'Edicifio con pilar incrustado [235238]
Edicifio32 con pi-lar incrus_tado 235234
Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 235
Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 3 ';
my $regex = qr/(\d+\n)|(\d+]\n)|(\d\s+\n)|(\d+$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}