#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d+\n)|(\d+]\n)|(\d\s+\n)|(\d+$)"
Local $sString = "Edicifio con pilar incrustado [235238]" & @CRLF & _
"Edicifio32 con pi-lar incrus_tado 235234" & @CRLF & _
"Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 235 " & @CRLF & _
"Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 3 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")