re = /(\d+\n)|(\d+]\n)|(\d\s+\n)|(\d+$)/
str = 'Edicifio con pilar incrustado [235238]
Edicifio32 con pi-lar incrus_tado 235234
Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 235
Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 3 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end