const regex = /(\d+\n)|(\d+]\n)|(\d\s+\n)|(\d+$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+\\n)|(\\d+]\\n)|(\\d\\s+\\n)|(\\d+$)', 'g')
const str = `Edicifio con pilar incrustado [235238]
Edicifio32 con pi-lar incrus_tado 235234
Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 235
Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 3 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}