// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+\n)|(\d+]\n)|(\d\s+\n)|(\d+$)").unwrap();
let string = "Edicifio con pilar incrustado [235238]
Edicifio32 con pi-lar incrus_tado 235234
Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 235
Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 3 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}