import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+\\n)|(\\d+]\\n)|(\\d\\s+\\n)|(\\d+$)";
final String string = "Edicifio con pilar incrustado [235238]\n"
+ "Edicifio32 con pi-lar incrus_tado 235234\n"
+ "Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 235 \n"
+ "Edicifio453 sdfcf.,-)(on pi[3564]lar indf245crustado 3 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}