// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0*(?:[1-9][0-9]{2,}|[2-9][0-9]|1[5-9])$").unwrap();
let string = "03
5
10
14
15
16
20
30
39
40
41
50
100
1000
//Reference: https://stackoverflow.com/questions/52700629/to-match-any-number-greater-than-15-using-regexp";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}