import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0*(?:[1-9][0-9]{2,}|[2-9][0-9]|1[5-9])$";
final String string = "03\n"
+ "5\n"
+ "10\n"
+ "14\n"
+ "15\n"
+ "16\n"
+ "20\n"
+ "30\n"
+ "39\n"
+ "40\n"
+ "41\n"
+ "50\n"
+ "100\n"
+ "1000\n"
+ "//Reference: https://stackoverflow.com/questions/52700629/to-match-any-number-greater-than-15-using-regexp";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}