# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^0*(?:[1-9][0-9]{2,}|[2-9][0-9]|1[5-9])$"
test_str = ("03\n"
"5\n"
"10\n"
"14\n"
"15\n"
"16\n"
"20\n"
"30\n"
"39\n"
"40\n"
"41\n"
"50\n"
"100\n"
"1000\n"
"//Reference: https://stackoverflow.com/questions/52700629/to-match-any-number-greater-than-15-using-regexp")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.