using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0*(?:[1-9][0-9]{2,}|[2-9][0-9]|1[5-9])$";
string input = @"03
5
10
14
15
16
20
30
39
40
41
50
100
1000
//Reference: https://stackoverflow.com/questions/52700629/to-match-any-number-greater-than-15-using-regexp";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}