const regex = /^0*(?:[1-9][0-9]{2,}|[2-9][0-9]|1[5-9])$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0*(?:[1-9][0-9]{2,}|[2-9][0-9]|1[5-9])$', 'mg')
const str = `03
5
10
14
15
16
20
30
39
40
41
50
100
1000
//Reference: https://stackoverflow.com/questions/52700629/to-match-any-number-greater-than-15-using-regexp`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}