#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0*(?:[1-9][0-9]{2,}|[2-9][0-9]|1[5-9])$"
Local $sString = "03" & @CRLF & _
"5" & @CRLF & _
"10" & @CRLF & _
"14" & @CRLF & _
"15" & @CRLF & _
"16" & @CRLF & _
"20" & @CRLF & _
"30" & @CRLF & _
"39" & @CRLF & _
"40" & @CRLF & _
"41" & @CRLF & _
"50" & @CRLF & _
"100" & @CRLF & _
"1000" & @CRLF & _
"//Reference: https://stackoverflow.com/questions/52700629/to-match-any-number-greater-than-15-using-regexp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")