package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0*(?:[1-9][0-9]{2,}|[2-9][0-9]|1[5-9])$`)
var str = `03
5
10
14
15
16
20
30
39
40
41
50
100
1000
//Reference: https://stackoverflow.com/questions/52700629/to-match-any-number-greater-than-15-using-regexp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}