import Foundation
let pattern = #"(^.{33})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
=IFERROR(
MAX(
INDEX(
raw_wells_prod!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
),
INDEX(
raw_wells_inj!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
)
),
0
)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"exprS = exprS & TrimRight("$1") & _"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)