// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^.{33})").unwrap();
let string = "=IFERROR(
MAX(
INDEX(
raw_wells_prod!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
),
INDEX(
raw_wells_inj!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
)
),
0
) ";
let substitution = "exprS = exprS & TrimRight(\"$1\") & _";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}