package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^.{33})`)
var str = `=IFERROR(
MAX(
INDEX(
raw_wells_prod!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
),
INDEX(
raw_wells_inj!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
)
),
0
) `
var substitution = "exprS = exprS & TrimRight("$1") & _"
fmt.Println(re.ReplaceAllString(str, substitution))
}