# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^.{33})"
test_str = ("=IFERROR( \n"
" MAX( \n"
" INDEX( \n"
" raw_wells_prod!R1, \n"
" MATCH( \n"
" 1, \n"
" raw_wells_prod!R, \n"
" 0 \n"
" ) \n"
" ), \n"
" INDEX( \n"
" raw_wells_inj!R1, \n"
" MATCH( \n"
" 1, \n"
" raw_wells_prod!R, \n"
" 0 \n"
" ) \n"
" ) \n"
" ), \n"
" 0 \n"
") ")
subst = "exprS = exprS & TrimRight(\"$1\") & _"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.