use strict;
my $str = '=IFERROR(
MAX(
INDEX(
raw_wells_prod!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
),
INDEX(
raw_wells_inj!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
)
),
0
) ';
my $regex = qr/(^.{33})/mp;
my $subst = 'exprS = exprS & TrimRight("$1") & _';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";