import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.{33})";
final String string = "=IFERROR( \n"
+ " MAX( \n"
+ " INDEX( \n"
+ " raw_wells_prod!R1, \n"
+ " MATCH( \n"
+ " 1, \n"
+ " raw_wells_prod!R, \n"
+ " 0 \n"
+ " ) \n"
+ " ), \n"
+ " INDEX( \n"
+ " raw_wells_inj!R1, \n"
+ " MATCH( \n"
+ " 1, \n"
+ " raw_wells_prod!R, \n"
+ " 0 \n"
+ " ) \n"
+ " ) \n"
+ " ), \n"
+ " 0 \n"
+ ") ";
final String subst = "exprS = exprS & TrimRight(\"$1\") & _";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}