$re = '/(^.{33})/m';
$str = '=IFERROR(
MAX(
INDEX(
raw_wells_prod!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
),
INDEX(
raw_wells_inj!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
)
),
0
) ';
$subst = "exprS = exprS & TrimRight(\"$1\") & _";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;