import Foundation
let pattern = #"define[\s]*\([\s]*\["#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
define(function(require, exports, module) {
var UIKit = require('uikit/uikit');
var ExtendUtil = require('helpers/extend.util');
var ConfirmModalView = UIKit.Modal2.extend({
define([
'underscore',
'marionette',
'../libs/spf.helper',
'../templates',
'uikit/injector',
'uikit/component.collection.view',
'uikit/grid',
'uikit/table',
'uikit/text',
'uikit/button'
], function(_, Mn,
// data stuff
SPFHelper,
Templates,
// view stuff
InjectorView, ComponentCollectionView, GridView, TableView, TextView, ButtonView) {
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)