# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"define[\s]*\([\s]*\["
test_str = ("define(function(require, exports, module) {\n"
" var UIKit = require('uikit/uikit');\n"
" var ExtendUtil = require('helpers/extend.util');\n\n\n"
" var ConfirmModalView = UIKit.Modal2.extend({\n\n\n"
"define([\n"
" 'underscore',\n"
" 'marionette',\n\n"
" '../libs/spf.helper',\n\n"
" '../templates',\n\n"
" 'uikit/injector',\n"
" 'uikit/component.collection.view',\n"
" 'uikit/grid',\n"
" 'uikit/table',\n"
" 'uikit/text',\n"
" 'uikit/button'\n"
" ], function(_, Mn,\n"
" // data stuff\n"
" SPFHelper,\n\n"
" Templates,\n"
" // view stuff\n"
" InjectorView, ComponentCollectionView, GridView, TableView, TextView, ButtonView) {")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.