use strict;
my $str = 'define(function(require, exports, module) {
var UIKit = require(\'uikit/uikit\');
var ExtendUtil = require(\'helpers/extend.util\');
var ConfirmModalView = UIKit.Modal2.extend({
define([
\'underscore\',
\'marionette\',
\'../libs/spf.helper\',
\'../templates\',
\'uikit/injector\',
\'uikit/component.collection.view\',
\'uikit/grid\',
\'uikit/table\',
\'uikit/text\',
\'uikit/button\'
], function(_, Mn,
// data stuff
SPFHelper,
Templates,
// view stuff
InjectorView, ComponentCollectionView, GridView, TableView, TextView, ButtonView) {';
my $regex = qr/define[\s]*\([\s]*\[/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}