package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`define[\s]*\([\s]*\[`)
var str = `define(function(require, exports, module) {
var UIKit = require('uikit/uikit');
var ExtendUtil = require('helpers/extend.util');
var ConfirmModalView = UIKit.Modal2.extend({
define([
'underscore',
'marionette',
'../libs/spf.helper',
'../templates',
'uikit/injector',
'uikit/component.collection.view',
'uikit/grid',
'uikit/table',
'uikit/text',
'uikit/button'
], function(_, Mn,
// data stuff
SPFHelper,
Templates,
// view stuff
InjectorView, ComponentCollectionView, GridView, TableView, TextView, ButtonView) {`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}