import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "define[\\s]*\\([\\s]*\\[";
final String string = "define(function(require, exports, module) {\n"
+ " var UIKit = require('uikit/uikit');\n"
+ " var ExtendUtil = require('helpers/extend.util');\n\n\n"
+ " var ConfirmModalView = UIKit.Modal2.extend({\n\n\n"
+ "define([\n"
+ " 'underscore',\n"
+ " 'marionette',\n\n"
+ " '../libs/spf.helper',\n\n"
+ " '../templates',\n\n"
+ " 'uikit/injector',\n"
+ " 'uikit/component.collection.view',\n"
+ " 'uikit/grid',\n"
+ " 'uikit/table',\n"
+ " 'uikit/text',\n"
+ " 'uikit/button'\n"
+ " ], function(_, Mn,\n"
+ " // data stuff\n"
+ " SPFHelper,\n\n"
+ " Templates,\n"
+ " // view stuff\n"
+ " InjectorView, ComponentCollectionView, GridView, TableView, TextView, ButtonView) {";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}