$re = '/define[\s]*\([\s]*\[/';
$str = 'define(function(require, exports, module) {
var UIKit = require(\'uikit/uikit\');
var ExtendUtil = require(\'helpers/extend.util\');
var ConfirmModalView = UIKit.Modal2.extend({
define([
\'underscore\',
\'marionette\',
\'../libs/spf.helper\',
\'../templates\',
\'uikit/injector\',
\'uikit/component.collection.view\',
\'uikit/grid\',
\'uikit/table\',
\'uikit/text\',
\'uikit/button\'
], function(_, Mn,
// data stuff
SPFHelper,
Templates,
// view stuff
InjectorView, ComponentCollectionView, GridView, TableView, TextView, ButtonView) {';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);