re = /define[\s]*\([\s]*\[/
str = 'define(function(require, exports, module) {
var UIKit = require(\'uikit/uikit\');
var ExtendUtil = require(\'helpers/extend.util\');
var ConfirmModalView = UIKit.Modal2.extend({
define([
\'underscore\',
\'marionette\',
\'../libs/spf.helper\',
\'../templates\',
\'uikit/injector\',
\'uikit/component.collection.view\',
\'uikit/grid\',
\'uikit/table\',
\'uikit/text\',
\'uikit/button\'
], function(_, Mn,
// data stuff
SPFHelper,
Templates,
// view stuff
InjectorView, ComponentCollectionView, GridView, TableView, TextView, ButtonView) {'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end