// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b[^2\n]\d{6,12}\b").unwrap();
let string = "21234567
99912234
19123809
21234567
21234567
21234567
21234567
21234567
21234567
21234567";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}