package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[^2\n]\d{6,12}\b`)
var str = `21234567
99912234
19123809
21234567
21234567
21234567
21234567
21234567
21234567
21234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}