#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b[^2\n]\d{6,12}\b"
Local $sString = "21234567" & @CRLF & _
"99912234" & @CRLF & _
"19123809" & @CRLF & _
"21234567" & @CRLF & _
"21234567" & @CRLF & _
"21234567" & @CRLF & _
"21234567" & @CRLF & _
"21234567" & @CRLF & _
"21234567" & @CRLF & _
"21234567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")