using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[^2\n]\d{6,12}\b";
string input = @"21234567
99912234
19123809
21234567
21234567
21234567
21234567
21234567
21234567
21234567";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}