$re = '/\b[^2\n]\d{6,12}\b/';
$str = '21234567
99912234
19123809
21234567
21234567
21234567
21234567
21234567
21234567
21234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);