const regex = /\b[^2\n]\d{6,12}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[^2\\n]\\d{6,12}\\b', 'g')
const str = `21234567
99912234
19123809
21234567
21234567
21234567
21234567
21234567
21234567
21234567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}