import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[^2\\n]\\d{6,12}\\b";
final String string = "21234567\n"
+ "99912234\n"
+ "19123809\n"
+ "21234567\n"
+ "21234567\n"
+ "21234567\n"
+ "21234567\n"
+ "21234567\n"
+ "21234567\n"
+ "21234567";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}