re = /^(\+?56){0,1}(9)[98765]\d{7}$/m
str = '+56932165481
965432189
+56986549874
+56965487d+ 56 9
+56 9 87135689
+569 8765321
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end