import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+?56){0,1}(9)[98765]\\d{7}$";
final String string = "+56932165481\n"
+ "965432189\n"
+ "+56986549874\n"
+ "+56965487d+ 56 9\n"
+ "+56 9 87135689\n"
+ "+569 8765321\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}